Портал компании

Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация

Автоматизация Бизнеса

Автоматизация сервисного центра

Программа для сервисных центров и ЦТО
Подробнее

Доработки для 1С

Любые доработки систем 1С всего за 900 р.час. Возможно уже есть готовые. Полный каталог разработок

Учет товаров по серийным номерам

Модуль позволяющий вести учет по серийным номерам и выводить на печать гарантийные талоны. Подробнее

Дополнение для автосервиса

Автоматизация СТО, шиномонтажной мастерской или мойки. Ознакомиться

Рассылка СМС

Уведомление клиентов или сотрудников с помощью СМС сообщений из 1С. Перейти

Модули, дополнения и отчеты для 1С

Больший список готовых решений для Вашей компании. Поддержка и сопровождение. Полный каталог разработок

Корзина

Ваша корзина пуста
Персональный раздел

 

Быстрый переход

 

Корзина

Доставка

Контакты

FAQ






Яндекс.Метрика



Меню раздела:

Быстрый поиск

 

Информация




Реклама

 

Подключение ККМ онлайн к Управление Торговлей 10.3 и другим современным конфигурациям


15.03.2017

Подключение ККМ онлайн к Управление Торговлей 10.3 и другим современным конфигурациям

Вот список проблем, с которыми приходится сталкиваться и краткое описание их решений. Более подробное описание со скриншотами ниже.


1. Компьютеры с Widows 10 Home не могут установить корректно драйвер Атол ТО. Решение от ЦТО - купить и использовать версию операционки проф за +15 тр. Решение - включил в операционке и биосе возможность установки не подписанных драйверов (не слетает при перезагрузке).


2. При работе через терминал и с пробросской COM портов чек выходит с колосальной задержкой и тупняком в 13 секунд.  Решение от ЦТО - работать локально, 1С установить локально, сервер принести в локалку с компьютером и кассой. Решение - отказаться от классической пробросски COM-портов в терминале, использовать службу драйвера ККМ АТОЛ, к которой можно подключиться из терминала через интернет. Работает мгновенно.


3. При начале работы система сообщает, что смена не открыта. Теперь есть журнал кассовых смен в УТ 10.3. Открывать и закрывать смены нужно в нем. Автоматически смена не открывается. 


Теперь по порядку.

Подключение ККМ к операционной системе Windows 10 Home

1.      Вся проблема заключается в том, что на данной операционной системе нельзя устанавливать не подписанные фирмой Microsoft драйвера. Поэтому, нужно включить такую возможность дополнительно

2.      Отключаем проверку подписи драйверов навсегда — с использованием командной строки для редактирования параметров загрузки.

 

2.1 В BIOS требуется отключить Secure Boot (это обязательно).

 

2.2 Запустите командную строку Windows 10 от имени администратора. В командной строке по порядку введите следующие две команды:
bcdedit.exe -set loadoptions DISABLE_INTEGRITY_CHECKS
bcdedit.exe -set TESTSIGNING ON

Отключение проверки подписи драйверов в командной строке
После того, как обе команды будут выполнены, закройте командную строку и перезагрузите компьютер. Проверка цифровых подписей будет отключена, с одним лишь нюансом: в правом нижнем углу вы будете наблюдать уведомление о том, что Windows 10 работает в тестовом режиме (чтобы убрать надпись и вновь включить проверку, введите в командной строке bcdedit.exe -set TESTSIGNING OFF). 
3.  Если при подключении к кассе через COM порт вы видите ошибку типа "Нет связи -1", то нужно все перезагрузить (и кассу), если не поможет, то на COM порты нужно установить вместо стандартных Winsows Драйверов драйвера из каталога с установленным драйвером ККТ.

Установка драйверов

1.   Устанавливаем Атоловские драйвера на локальный компьютер и на терминальный сервер


2. Присваиваем локальному компьютеру постоянный статический IP адрес, например 192.168.1.4

3. Отключить нужно обязательно IP v6

4. Отключить нужно так же и брендмауэр Windows или добавить нужный порт в список исключений

5. На роутере в локальной сети с кассой сделать проброску порта 6220  на компьютер кассира

6. ЭТОТ ПУНКТ НЕ ОБЯЗАТЕЛЕН, он для проверки. Переходим к настройкам на терминальном сервере. В драйвере ККМ выполняем тестовое подключение по порту 6220 указав внешний IP адрес подсети с нашей кассой

7. Проверяем подключение, все должно мгновенно сработать

Подключение кассы к 1С

1.      Важно помнить, что никакие кассовые смены автоматически не открываются (пишет что кассовая смена не открыта), т. к. это написано в интерете, открывать ее нужно в 1С дополнительно ежедневно (ежесменно).

2.      В настройках торгового оборудования добавляем нашу ККТ с передачей данных, загружая драйвер с сайта ИТС

3. В параметрах подключения нужно не забыть указать компьютер (внешний ip адрес) и порт

4. С настройками покончено, переходим к открытиям смены


Для работы в терминале клавиатурного (в режиме USB-HID) сканера ШК 

Отказываясь от проброски COM портов, реализуем повторное нажатие клавиши F7 после первого сканирования товаров в документ Чек ККМ. Сканер вообще не нужно подключать как торговое оборудование.

Процедура формы документа чек ККМ:

Функция СШКНоменклатура(Номенклатура, Характеристика, Серия, Качество,

                        Единица, Количество, СШК) Экспорт


Результат        = Истина;

ИмяТекСтраницы   = ЭлементыФормы.ПанельТовары.ТекущаяСтраница.Имя;

СтруктураПодбора = РаботаСТорговымОборудованием.СформироватьСтруктуруПодбора(Дата, Номенклатура, Характеристика,

                                               Серия, Качество, Единица,

                                               Количество, мВалютаРегламентированногоУчета,

                                               Неопределено, мУказаниеСкладовВТЧ,

                                               ТипЦен, , , УсловиеПродаж, Склад);


Если      ИмяТекСтраницы = "Товары" Тогда

ОбработкаПодбора(Товары, СтруктураПодбора);

Иначе

Предупреждение("На странице """

              + ИмяТекСтраницы

              + """ подбор номенклатуры не предусмотрен.");

КонецЕсли;


//!нажмем еще раз F7

КоманднаяПанельТоварыПоискПоШтрихКоду(ЭлементыФормы.КоманднаяПанельТовары.Кнопки.ПоискПоШтрихКоду) ;

Возврат Результат;


КонецФункции // СШКНоменклатура()




Подключение торгового оборудования по RDP для конкретного пользователя

В модуле обработки ТОСервер в 1С заменим код в процедуре для привязки к пользователю


Функция ПолучитьИмяКомпьютераТО() Экспорт


//Если мИмяКомпьютера = Неопределено Тогда

// мИмяКомпьютера = ВРег(ИмяКомпьютера());

//КонецЕсли;


//Возврат мИмяКомпьютера;

//в имя компьютера добавим название пользователя, тогда торговое оборудование только к нему будет подцепляться

Если мИмяКомпьютера = Неопределено Тогда 

мИмяКомпьютера = ВРег(ИмяКомпьютера()); 

Если Константы.ТорговоеОборудованиеИспользуетсяНаСервереТерминала.Получить() = истина тогда 

мИмяКомпьютера = мИмяКомпьютера + "_"+глЗначениеПеременной("глТекущийПользователь");

КонецЕсли;

КонецЕсли;

Возврат мИмяКомпьютера; 


КонецФункции // ПолучитьИмяКомпьютераТО()



Работа кассира (полный интерфейс)

1.      Запускаем обработку Кассовые смены из меню торгового оборудования, работа с ККМ

2.      Выбираем наш кассовый аппарат и жмем открытие смены

3.   Теперь при проведении чеков ккм у нас все будет печататься

4.      Аналогичным образом работает и кнопка закрытия смены


Количество показов: 74693

Возврат к списку

(Голосов: 5, Рейтинг: 3.75)

Гость, 12.05.2017 05:41:07
Данное решение будет работать только для касс Атол? Для дримскасс его запилить реально?
Виталий, 11.04.2017 14:07:44
Всем привет, от себя добавлю, проверьте еще это Пуск\Панель управления\Все элементы панели управления\Учетные записи пользователей и включите на третий уровень как и было при установке параметры контроля учетных записей
Перейти к обсуждению на форуме >>

Модули   Статьи   Отзывы   Кабинет   Поддержка  
@ !pride, 1module. Все права защищены. 2003 - 2018