Портал компании
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Автоматизация Бизнеса
Сервисный центр 1С

Автоматизация сервисного центра

Программа для сервисных центров и ЦТО
Подробнее

Программист 1С

Доработки для 1С

Любые доработки систем 1С всего за 1700 р.час. Возможно уже есть готовые. Полный каталог разработок

Разработки для 1С
Учет по серийным номерам 1С

Учет товаров по серийным номерам

Модуль позволяющий вести учет по серийным номерам и выводить на печать гарантийные талоны. Подробнее

Автосервис 1С

Дополнение для автосервиса

Автоматизация СТО, шиномонтажной мастерской или мойки. Ознакомиться

Рассылка SMS 1С

Рассылка СМС

Уведомление клиентов или сотрудников с помощью СМС сообщений из 1С. Перейти

Модули для 1С

Модули, дополнения и отчеты для 1С

Больший список готовых решений для Вашей компании. Поддержка и сопровождение. Полный каталог разработок

 

Быстрый переход





Яндекс.Метрика
Меню раздела:

Быстрый поиск

 

Информация



 

[CODE] Кнопка печать через БСП (Программно 1С)



&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
	ТабДокумент = Заполнялка(ПараметрКоманды);
	//Создаём новую коллекцию печатных форм
	КоллекцияПечатныхФорм = УправлениеПечатьюКлиент.НоваяКоллекцияПечатныхФорм("ПечатьБланка");
	//Добавляем в коллекцию сформированный табличный документ
	КоллекцияПечатныхФорм[0].ТабличныйДокумент = ТабДокумент;
	//Устанавливаем параметры печати (при необходимости)
	КоллекцияПечатныхФорм[0].Экземпляров = 1;
	КоллекцияПечатныхФорм[0].СинонимМакета = "ПечатьБланка";  //Так будет выглядеть имя файла при сохранении в файл из формы "Печать документов"
	//Вывод через стандартную процедуру БСП
	УправлениеПечатьюКлиент.ПечатьДокументов(КоллекцияПечатныхФорм, Неопределено, Неопределено);
КонецПроцедуры

&НаСервере
Функция ПолучениеМакета(ДокСсылка)
	Попытка
		Макет = УправлениеПечатью.МакетПечатнойФормы("Документ.пмДокументАвтосервиса.ПФ_MXLПечатьЗаказНаряд");
	исключение
		Макет = ДокСсылка.ПолучитьОбъект().ПолучитьМакет("ПФ_MXLПечатьЗаказНаряд");
	КонецПопытки;
	Возврат Макет;
КонецФункции

&НаСервере
Функция Заполнялка(ДокСсылка) Экспорт
	ТабДокумент = Новый ТабличныйДокумент;
	
	ТабДокумент.АвтоМасштаб = истина ;
	ТабДокумент.ОтображатьСетку = Ложь;
	ТабДокумент.ТолькоПросмотр = Истина;
	ТабДокумент.ОтображатьЗаголовки = Ложь;
	
	
	Макет = ПолучениеМакета(ДокСсылка);
	
	СсылкаНаОбъект = ДокСсылка ;
	
	ОбластьМакета = Макет.ПолучитьОбласть("Область1");
	ОбластьМакета.Параметры.ЮрЛицо    = ДокСсылка.Организация.НаименованиеСокращенное ;
	
	ТабДокумент.Вывести(ОбластьМакета);
	
	Возврат ТабДокумент;
КонецФункции


Количество показов: 573
Дата изменения: 20.11.2023 07:01:53

Возврат к списку

(Нет голосов)

Ваше имя:
Защита от автоматических сообщений:
Защита от автоматических сообщений Символы на картинке:


Модули   Статьи   Отзывы   Кабинет   Поддержка  
@ !pride, 1module. Все права защищены. 2003 - 2024