Портал компании
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Автоматизация Бизнеса
Сервисный центр 1С

Автоматизация сервисного центра

Программа для сервисных центров и ЦТО
Подробнее

Программист 1С

Доработки для 1С

Любые доработки систем 1С всего за 1500 р.час. Возможно уже есть готовые. Полный каталог разработок

Разработки для 1С
Учет по серийныйм номерам 1С

Учет товаров по серийным номерам

Модуль позволяющий вести учет по серийным номерам и выводить на печать гарантийные талоны. Подробнее

Автосервис 1С

Дополнение для автосервиса

Автоматизация СТО, шиномонтажной мастерской или мойки. Ознакомиться

Рассылка SMS 1С

Рассылка СМС

Уведомление клиентов или сотрудников с помощью СМС сообщений из 1С. Перейти

Модули для 1С

Модули, дополнения и отчеты для 1С

Больший список готовых решений для Вашей компании. Поддержка и сопровождение. Полный каталог разработок

 

Быстрый переход





Яндекс.Метрика
Меню раздела:

Быстрый поиск

 

Информация




 

Тип Структура параметров



//Передача
&НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
	СтандартнаяОбработка = ложь ;
	
	СтруктураПараметровОтбора = Новый Структура();
	СтруктураПараметровОтбора.Вставить("Документ", Элемент.ТекущиеДанные.Ссылка)  ;
	СтруктураПараметровОтбора.Вставить("Картридж", Элемент.ТекущиеДанные.Картридж)           ;
	СтруктураПараметровОтбора.Вставить("СерийныйНомер",Элемент.ТекущиеДанные.СерийныйНомер)           ;
	
	ОткрытьФорму("Обработка.пмРаботаСКартриджем.Форма.Форма", СтруктураПараметровОтбора, ЭтаФорма);
КонецПроцедуры

//Получение
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	СтруктураПараметровОтбора = Новый Структура();
	СтруктураПараметровОтбора.Вставить("Документ", Документы.УниверсальныйСервис.ПустаяСсылка())  ;
	СтруктураПараметровОтбора.Вставить("Картридж", Справочники.Номенклатура.ПустаяСсылка())           ;
	СтруктураПараметровОтбора.Вставить("СерийныйНомер", "")           ;
	
	Если Параметры <> Неопределено Тогда
		ЗаполнитьЗначенияСвойств(СтруктураПараметровОтбора, Параметры);
	КонецЕсли;
КонецПроцедуры


Количество показов: 20
Дата изменения: 15.08.2022 18:13:35

Возврат к списку

(Нет голосов)

Ваше имя:
Защита от автоматических сообщений:
Защита от автоматических сообщений Символы на картинке:


Модули   Статьи   Отзывы   Кабинет   Поддержка  
@ !pride, 1module. Все права защищены. 2003 - 2022